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Uploading Lumi Content to Canvas 
Use the following instructions to add your Lumi files to Canvas as either course files, SCORM 

packages, or iframes. All images were taken from a PC, but instructions remain the same for 

Mac users. 

 

Upload as Course File 

1. Export content from Lumi Desktop App to your computer as an All-in-one HTML file 

File > Export > select All-in-one HTML file > Export Now > Export (this action saves the file to the  

 

 

 

 

 

2. Upload HTML file into Canvas Files 

Open your Canvas course > navigate to your 

files > Upload > select HTML file > Open 

Uploading Lumi Content to Canvas 
Use the following instructions to add your Lumi files to Canvas as either course files, SCORM 
packages, or iframes. All images were taken from a PC, but instructions remain 
the same for Mac users. 

*NOTE: Users cannot export HTML files from Lumi online/cloud version. If you work with the Lumi online 

version, you can download the H5P file and upload it to the Lumi Desktop App. Instructions to do this are 

on the last page of this document. 

Upload as Course File 

Export content from Lumi Desktop App 
to your computer as an All-in-one HTML 
file. File > Export > select All-in-one 
HTML file > Export Now > Export 
(this action saves the file to the 
computer).

Upload HTML file into Canvas Files. 
Open your Canvas course > navigate 
to your files > Upload > select 
HTML file > Open.
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3. Add to Canvas Page or Module 

To add to a Canvas Page: Go to Pages > Open page > Edit > Open Course Documents > Select file 

to add to page. 

 

 

To add to Module: Go to Modules > Click + next to 

Module > Select “File” from dropdown menu > Select 

file > Add item 

 

 

 

 

 

 

 

4. Edit display text/title with Link Options 

Click on attachment > Link Options > Edit text > Done 

 

  

 

 

 

5. Save your work at the bottom of the page!  

Add to Canvas Page or Module. To 
add to a Canvas Page: Go to Pages 
> Open page > Edit > Open 
Course Documents > Select 
file to add to page. To add to 
Module: Go to Modules > Click + 
next to Module > Select �File� 
from dropdown menu > Select 
file > Add item.
Edit display text/title with Link Options. 
Click on attachment > Link 
Options > Edit text > Done.

Save your work at the bottom of the page!
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Upload Lumi Content to Canvas with SCORM 

 

Upload Lumi Content to Canvas with SCORM 

*NOTE: SCORM is the only file type that has the ability to grade an assignment. 
 

1. Export file from Lumi Desktop App as a SCORM Package 

File > Export > select SCORM Package > Export Now > Export (this action saves the file to the 

location you’ve selected) 

*NOTE: The Mastery score under the export settings does not affect the score or grade of the activity in 

Canvas 

 

 

 

 

2. Upload content to SCORM page in Canvas Course navigation menu 

Open Canvas course > open SCORM from navigation menu > Upload > Select file > Open 

 

*NOTE: If SCORM is not already enabled in your Navigation Menu, you’ll have to enable it by going to 

Settings at the bottom of the Course Navigation Menu > Navigation tab > Drag SCORM from the hidden 

pages to the active navigation menu  

Export file from Lumi Desktop App as a SCORM 
Package. File > Export > select SCORM 
Package > Export Now > Export (this 
action saves the file to the location you�ve 
selected). *NOTE: The Mastery score 
under the export settings does not affect 
the score or grade of the activity in Canvas.

Upload content to SCORM page in Canvas Course navigation 
menu. Open Canvas course > open SCORM 
from navigation menu > Upload > Select file > Open. 
*NOTE: If SCORM is not already enabled in your 
Navigation Menu, you�ll have to enable it by going 
to Settings at the bottom of the Course Navigation 
Menu > Navigation tab > Drag SCORM from 
the hidden pages to the active navigation menu.
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3. Select content type as an Assignment or Page 

Once the upload is complete, the file will appear on the SCORM page with a box to choose what 

type of content you’d like to import the file as. It can be a graded or ungraded assignment or a 

course page. The type you select will determine where the file will be located, either under 

“Assignments” or “Pages.” 

 

 

 

 

4. Add to Module (if you’d like) 

If you want to add your content to a module, open the Modules page and click the + next to the 

module you want to add to. Depending on the import type you chose (either an assignment or 

page), select that option from the dropdown menu and click the file you want to add to the 

module. Then, select Add Item. 

 

 

 

 

 

 

 

 

 

 

Select content type as an Assignment or Page. Once the upload 
is complete, the file will appear on the SCORM page with 
a box to choose what type of content you�d like to import 
the file as. It can be a graded or ungraded assignment or 
a course page. The type you select will determine where the 
file will be located, either under �Assignments� or �Pages.�

Add to Module (if you�d like). If you want to add your content to a module, open the 
Modules page and click the + next to the module you want to add to. Depending 
on the import type you chose (either an assignment or page), select that 
option from the dropdown menu and click the file you want to add to the module. 
Then, select Add Item.
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Upload Lumi Content to Canvas Pages with iframe 

 
1. Export H5P file from Lumi Desktop App to your computer as an All-in-one HTML file 

File > Export > select All-in-one HTML file > Export Now > Export/Save to files 

 

 

 

 

 

2. Upload HTML file into Canvas Files 

Open Canvas course > Files > Upload > select HTML file > Open 

*NOTE: Make sure to select the HTML file (.html), NOT the original H5P file (.h5p file)  

 

 

 

3. Copy and paste iframe code into a text editor 

Copy the code below and paste it into a text editor (Notepad, TextEdit, Word/Google document, 

etc). You will be pasting the link from the next step into this code. 
 

Upload Lumi Content to Canvas Pages with iframe 

Export H5P file from Lumi Desktop 
App to your computer as an 
All-in-one HTML file. File > Export 
> select All-in-one HTML file 
> Export Now > Export/Save to 
files.

 

 

Upload HTML file into Canvas Files. Open Canvas 
course > Files > Upload > select HTML 
file > Open. *NOTE: Make sure to select 
the HTML file (.html), NOT the original 
H5P file (.h5p file).

Copy and paste iframe code into a text editor. Copy the code below and paste it into 
a text editor (Notepad, TextEdit, Word/Google document, etc). You will be pasting 
the link from the next step into this code.

<iframe src="PASTE_YOUR_LINK_HERE" width="100%" height="500" style="border:1px solid black;">

</iframe>
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4. Copy link address 

Find the HTML file you uploaded to Canvas Files, right-click file 

name, select “Copy Link Address” or “Copy Link”, depending on 

your browser. 

*NOTE: “Copy to” from the ⋮ Options Menu will NOT work; you must 

right-click on the file to copy the link 

 

 

5. Paste copied link from Canvas into iframe code  

Replace the text “PASTE_YOUR_LINK_HERE” (after src=) with your copied link and delete the 

words – but keep the quotation marks “ “ at the beginning and the end 

  

 

 

 

 

 

 

 

 

6. Delete the unnecessary text from code 

After you paste the link into the code, you’ll need to delete some of the text at the end of the 

pasted link. Delete the ? and everything after it that comes before the closing quotation mark 

(before width) 

*NOTE: Do NOT delete the closing quotation mark, just text before. See picture for clarity. 

 

 

 

 

 

 

 

 

Copy link address. Find the HTML file you uploaded to Canvas 
Files, right-click file name, select �Copy Link Address� 
or �Copy Link�, depending on your browser. *NOTE: 
�Copy to� from the ￮ Options Menu will NOT work; you 
must right-click on the file to copy the link.

Paste copied link from Canvas into iframe code. 
Replace the text �PASTE_YOUR_LINK_HERE� 
(after src=) 
with your copied link and delete the words 
� but keep the quotation marks � � 
at the beginning and the end.
Delete the unnecessary text from code. After you paste 
the link into the code, you�ll need to delete some 
of the text at the end of the pasted link. Delete 
the ? and everything after it that comes before 
the closing quotation mark (before width). *NOTE: 
Do NOT delete the closing quotation mark, 
just text before. See picture for clarity.

6. Delete the unnecessary text from code After you 
paste the link into the code, you�ll need to delete 
some of the text at the end of the pasted link. 
Delete the ? and everything after it that comes 
before the closing quotation mark (before width) 
*NOTE: Do NOT delete the closing quotation 
mark, just text before. See picture for clarity. 
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7. Copy FULL code with pasted Canvas link 

Once you delete the unnecessary text, your code will be ready to be embedded into Canvas. The 

image shows what the full code should look like after the edits. Copy everything in the file. 

 

 

 

 

 

 

8. Embed copied code to your Canvas page 

Open the Canvas page that the Lumi content is 

intended for, click Edit and then click the area in 

the text editor where you want your content to 

be placed. Then click Insert > Embed 

 

 

 

 

 

 

9. Submit and Save 

Paste your copied code into the embed window and 

click Submit. The content will upload into your Canvas 

page. Then when you’re all done, click Save at the 

bottom of the page. Now you’re all set! 

Copy FULL code with pasted Canvas link. Once you delete 
the unnecessary text, your code will be ready to 
be embedded into Canvas. The image shows what 
the full code should look like after the edits. Copy 
everything in the file.

Embed copied code to your Canvas page. Open 
the Canvas page that the Lumi content 
is intended for, click Edit and then click 
the area in the text editor where you want 
your content to be placed. Then click Insert 
> Embed.

Submit and Save. Paste your copied code into the embed 
window and click Submit. The content will upload 
into your Canvas page. Then when you�re all 
done, click Save at the bottom of the page. Now you�re 
all set!
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*NOTE: The height of the iframe may 

be different from the length of your 

content. To adjust the size to fit your 

content, you can edit the “height” in 

the iframe code. To figure out the 

height needed, you’ll have to 

experiment with trial and error until 

you find what works best for you.  

This will help avoid an iframe that is 

larger than your content and has 

empty space, or an iframe that’s 

smaller than your content and 

requires you to scroll through the 

content within the small frame (See 

crossword example at right).  

You can also adjust the border width 

and color in the iframe code. 

 

*OPTIONAL: If your iframe has the entirety of the activity in view and you want to remove the 

scrollbar, you can add the attribute  scrolling="no" to your iframe code. 

*NOTE: The height of the iframe may be different 
from the length of your content. To 
adjust the size to fit your content, you can 
edit the �height� in the iframe code. To 
figure out the height needed, you�ll have 
to experiment with trial and error until you 
find what works best for you. 

This will help avoid an iframe that is larger 
than your content and has empty 
space, or an iframe that�s smaller 
than your content and requires 
you to scroll through the content 
within the small frame (See crossword 
example at right). 

You can also adjust the border width and color 
in the iframe code. 

*OPTIONAL: If your iframe has the entirety of the activity in view and you want to remove the scrollbar, 
you can add the attribute scrolling="no" to your iframe code. 
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